vRA / Re-installing the IaaS Server on the same Windows machine after a failure

Share Button

I recently started the deployment of a “lab” environment of vRA. To be transparent, I did this to present vRealize Business “Standard” to some clients that are holding the right to use the product but do not know the product and its benefits.

Anyway, I deployed this infrastructure (I may write an article on this deployment in a near future) :

  • Srv1 : vRealize Automation (vRA, formerly know as vCAC : vCloud Automation Center) 6.2 Appliance
  • Srv2 : IaaS Server (No appliance, so Windows 2K12 R2) ==> The IaaS server will host IaaS components, DEM Orchestrator, 1 DEM Worker and the vSphere Proxy Agent
  • Srv3 : Database Server : SQL Server 2K12 under Windows 2K12 R2 (not the IaaS Server)
  • Srv4 : vRealize Business (vRB, formerly know as ITBM : IT Business Management) 6.1.1 Appliance

I had some trouble to install the first time the IaaS Server and after some hours, it appears that the failures in the installation were generating more problems that I supposed at first : Finally I was missing the “Web Api” components.

This missing component does not prevent the registration of the IaaS server in the Cafe Server. I realized that something was going wrong when I faced this error while trying to deploy a blueprint “java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING.

I reviewed my entire deployment and came to the conclusion that I needed to reinstall the IaaS Server. Here is the technical procedure I followed :

  • Remove all the Business Group that were existing in any tenants you created : this is really important because, if you do not follow this step, the Cafe server will hold some references to Business Group that will not exist anymore after re-installing. This has to be done through the vRA portal of you different tenants.
  • Remove all the tenant (except vsphere.local obviously) with the “Administrative” Accounts
  • Uninstall from Windows all the components, meaning the IaaS Server, the DEM Orchestrator, the DEM Workers, the Proxy Agent/All the agents from Srv2
  • Destroyed the “vCAC” database on Srv3
  • Open the IIS Console, Right Click on “Default Web Site” (or any other website you configured during the installation), click “Edit Bindings” and Remove the “https / 433” Binding

Close all. I would also recommend a reboot, and just a few seconds later, you’re ready to start over a brand new installation of the vRA IaaS Server.

 

1,778 total views, 20 views today

Share Button

One Reply to “vRA / Re-installing the IaaS Server on the same Windows machine after a failure”

  1. Pingback: URL

Leave a Reply

Your email address will not be published. Required fields are marked *